Delivery API, Delivery Preview API, and Delivery GraphQL API Returning Outdated Content

Incident Report for Kontent.ai

Resolved

Between 13:56 UTC and 15:59 UTC, we experienced an issue with the latest content changes not being reflected in the Delivery API, Delivery Preview API, and Delivery GraphQL API. Webhook functionality was also affected because of this. These issues impacted all regions.

Our development team released a fix at 15:59 UTC, and after a period of monitoring, no further issues have been observed.
Posted Apr 15, 2025 - 16:39 UTC

Monitoring

Our development team has released a fix, and we are monitoring the results. The latest changes to content should now be reflected in the Delivery API.
Posted Apr 15, 2025 - 16:07 UTC

Update

We have identified that our webhooks are also being affected. Our development team is continuing to work on a fix.
Posted Apr 15, 2025 - 15:45 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 15, 2025 - 14:35 UTC

Identified

We have identified an issue where the Delivery API, Delivery Preview API, and Delivery GraphQL API are currently returning outdated content. Our development team will be releasing a fix soon.
Posted Apr 15, 2025 - 14:29 UTC
This incident affected: USA (Delivery REST API, Delivery GraphQL API, Webhook dispatcher), Europe (Delivery REST API, Delivery GraphQL API, Webhook dispatcher), APAC (Delivery REST API, Delivery GraphQL API, Webhook dispatcher), and Canada (Delivery REST API, Delivery GraphQL API, Webhook dispatcher).