Our development team has implemented a fix, and accessing an asset via its preview URL after upload is functioning as expected, with minimal delay in processing.
Posted Feb 17, 2026 - 20:12 UTC
Identified
There is currently a delay in the appearance of assets when accessing an asset's preview URL due to our preview storage being overloaded in the U.S. data center. Accessing the published version of an asset still functions as expected.
Posted Feb 16, 2026 - 11:13 UTC
This incident affected: USA (Delivery REST API, Delivery GraphQL API).